]> git.scottworley.com Git - paperdoorknob/blobdiff - default.nix
fetch: Verify caching across sessions
[paperdoorknob] / default.nix
index affb0683816190d9f9cfcd52f405a048db0c27d2..6331754cffa9704802efea37409ece886c61ba80 100644 (file)
@@ -1,11 +1,11 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
-pkgs.python3Packages.callPackage
-({ lib, buildPythonPackage, autopep8, mypy, pylint, requests, types-requests }:
+pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, autopep8, mypy
+  , pylint, requests, requests-cache, types-requests }:
   buildPythonPackage rec {
     pname = "paperdoorknob";
     version = "0.0.1";
     src = lib.cleanSource ./.;
-    propagatedBuildInputs = [ requests ];
+    propagatedBuildInputs = [ requests requests-cache ];
     nativeCheckInputs = [ mypy types-requests ]
       ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;