]> git.scottworley.com Git - paperdoorknob/blobdiff - default.nix
Parse HTML
[paperdoorknob] / default.nix
index affb0683816190d9f9cfcd52f405a048db0c27d2..bf96eb8c437f74b47d65a4b9a09ed4d9d258e55d 100644 (file)
@@ -1,12 +1,14 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
-pkgs.python3Packages.callPackage
-({ lib, buildPythonPackage, autopep8, mypy, pylint, requests, types-requests }:
+pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, autopep8, mypy
+  , pylint, beautifulsoup4, requests, requests-cache, types-beautifulsoup4
+  , types-requests, xdg-base-dirs }:
   buildPythonPackage rec {
     pname = "paperdoorknob";
     version = "0.0.1";
     src = lib.cleanSource ./.;
-    propagatedBuildInputs = [ requests ];
-    nativeCheckInputs = [ mypy types-requests ]
+    propagatedBuildInputs =
+      [ beautifulsoup4 requests requests-cache xdg-base-dirs ];
+    nativeCheckInputs = [ mypy types-beautifulsoup4 types-requests ]
       ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";