]> git.scottworley.com Git - paperdoorknob/blobdiff - default.nix
LaTeX output is a valid LaTeX file
[paperdoorknob] / default.nix
index 58f98862f305518503a2d8ee8896f882bb109897..3e02638098eb34a7f513f1a3701a4c8a3cde5828 100644 (file)
@@ -1,7 +1,8 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
 pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, makeWrapper
   , autopep8, mypy, pylint, beautifulsoup4, requests, requests-cache
-  , types-beautifulsoup4, types-requests, xdg-base-dirs, pandoc-cli }:
+  , texliveBasic, types-beautifulsoup4, types-requests, xdg-base-dirs
+  , pandoc-cli }:
   buildPythonPackage rec {
     pname = "paperdoorknob";
     version = "0.0.1";
@@ -9,7 +10,8 @@ pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, makeWrapper
     nativeBuildInputs = [ makeWrapper ];
     propagatedBuildInputs =
       [ beautifulsoup4 requests requests-cache xdg-base-dirs ];
-    nativeCheckInputs = [ mypy pandoc-cli types-beautifulsoup4 types-requests ]
+    nativeCheckInputs =
+      [ mypy pandoc-cli texliveBasic types-beautifulsoup4 types-requests ]
       ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";