]> git.scottworley.com Git - paperdoorknob/blobdiff - default.nix
Parse HTML
[paperdoorknob] / default.nix
index f73efb59f4bf6c6e8cd558be53f76550a5eda24c..bf96eb8c437f74b47d65a4b9a09ed4d9d258e55d 100644 (file)
@@ -1,11 +1,15 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
-pkgs.python3Packages.callPackage
-({ lib, buildPythonPackage, autopep8, mypy, pylint, }:
+pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, autopep8, mypy
+  , pylint, beautifulsoup4, requests, requests-cache, types-beautifulsoup4
+  , types-requests, xdg-base-dirs }:
   buildPythonPackage rec {
     pname = "paperdoorknob";
     version = "0.0.1";
     src = lib.cleanSource ./.;
-    nativeCheckInputs = [ mypy ] ++ lib.optionals lint [ autopep8 pylint ];
+    propagatedBuildInputs =
+      [ beautifulsoup4 requests requests-cache xdg-base-dirs ];
+    nativeCheckInputs = [ mypy types-beautifulsoup4 types-requests ]
+      ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";
     meta = {