]> git.scottworley.com Git - paperdoorknob/blobdiff - default.nix
Support _ in URLs
[paperdoorknob] / default.nix
index 58f98862f305518503a2d8ee8896f882bb109897..bb2d87e986b98702f61a0cd609030d26f81cb0ed 100644 (file)
@@ -1,15 +1,18 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
 pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, makeWrapper
   , autopep8, mypy, pylint, beautifulsoup4, requests, requests-cache
-  , types-beautifulsoup4, types-requests, xdg-base-dirs, pandoc-cli }:
+  , texliveFull, types-beautifulsoup4, types-requests, xdg-base-dirs
+  , pandoc-cli }:
   buildPythonPackage rec {
     pname = "paperdoorknob";
-    version = "0.0.1";
+    version = lib.removeSuffix "'" (lib.removePrefix "paperdoorknob_version = '"
+      (lib.fileContents ./version.py));
     src = lib.cleanSource ./.;
     nativeBuildInputs = [ makeWrapper ];
     propagatedBuildInputs =
       [ beautifulsoup4 requests requests-cache xdg-base-dirs ];
-    nativeCheckInputs = [ mypy pandoc-cli types-beautifulsoup4 types-requests ]
+    nativeCheckInputs =
+      [ mypy pandoc-cli texliveFull types-beautifulsoup4 types-requests ]
       ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";