]> git.scottworley.com Git - paperdoorknob/blobdiff - default.nix
FakeFetcher: Show bad URLs in error messages
[paperdoorknob] / default.nix
index 6bbed2273e21a61fed51aeda480968a10b06840a..c27c9e63ad0e21154daadcc17997e2a6a428d93e 100644 (file)
@@ -1,7 +1,8 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
 pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, makeWrapper
   , autopep8, mypy, pylint, beautifulsoup4, requests, requests-cache
-  , types-beautifulsoup4, types-requests, xdg-base-dirs, pandoc-cli }:
+  , texliveFull, types-beautifulsoup4, types-requests, xdg-base-dirs
+  , pandoc-cli }:
   buildPythonPackage rec {
     pname = "paperdoorknob";
     version = "0.0.1";
@@ -9,7 +10,8 @@ pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, makeWrapper
     nativeBuildInputs = [ makeWrapper ];
     propagatedBuildInputs =
       [ beautifulsoup4 requests requests-cache xdg-base-dirs ];
-    nativeCheckInputs = [ mypy types-beautifulsoup4 types-requests ]
+    nativeCheckInputs =
+      [ mypy pandoc-cli texliveFull types-beautifulsoup4 types-requests ]
       ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";