]> git.scottworley.com Git - paperdoorknob/blobdiff - default.nix
FakeFetcher: Show bad URLs in error messages
[paperdoorknob] / default.nix
index 3e02638098eb34a7f513f1a3701a4c8a3cde5828..c27c9e63ad0e21154daadcc17997e2a6a428d93e 100644 (file)
@@ -1,7 +1,7 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
 pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, makeWrapper
   , autopep8, mypy, pylint, beautifulsoup4, requests, requests-cache
-  , texliveBasic, types-beautifulsoup4, types-requests, xdg-base-dirs
+  , texliveFull, types-beautifulsoup4, types-requests, xdg-base-dirs
   , pandoc-cli }:
   buildPythonPackage rec {
     pname = "paperdoorknob";
@@ -11,7 +11,7 @@ pkgs.python3Packages.callPackage ({ lib, buildPythonPackage, makeWrapper
     propagatedBuildInputs =
       [ beautifulsoup4 requests requests-cache xdg-base-dirs ];
     nativeCheckInputs =
-      [ mypy pandoc-cli texliveBasic types-beautifulsoup4 types-requests ]
+      [ mypy pandoc-cli texliveFull types-beautifulsoup4 types-requests ]
       ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";