]> git.scottworley.com Git - nixos-qemu-vm-isolation/blobdiff - flake.nix
Use the new nixpkgs.lib.nixos.runTest interface for checks
[nixos-qemu-vm-isolation] / flake.nix
index ddce3f9f292a287d3c24b39afd0a56ecee033f7c..71b4beffc599d0dc052bcc5d7fc7dd1a27cd458e 100644 (file)
--- a/flake.nix
+++ b/flake.nix
@@ -13,8 +13,8 @@
         qemu-vm-isolation = import ./modules/qemu-vm-isolation.nix;
       };
       checks = forAllSystems (system: {
-        mount-grep = nixpkgs.legacyPackages."${system}".nixosTest
-          (import ./checks/mount-grep.nix);
+        mount-grep = nixpkgs.lib.nixos.runTest
+          (import ./checks/mount-grep.nix nixpkgs.legacyPackages."${system}");
       });
     };
 }