]> git.scottworley.com Git - nixos-qemu-vm-isolation/blobdiff - checks/mount-grep.nix
Use the new nixpkgs.lib.nixos.runTest interface for checks
[nixos-qemu-vm-isolation] / checks / mount-grep.nix
index 99084eaf3b8f461b9c934287a72db00e14f26fa6..90ae4a7d8e3c33b59228e3c81703ad4706bc3f2f 100644 (file)
@@ -1,12 +1,14 @@
-{ lib, pkgs, ... }: {
+pkgs: {
   name = "qemu-private-store-mount-grep";
 
+  hostPkgs = pkgs;
+
   nodes = {
     shared = _: { };
     private = _: { imports = [ ../modules/qemu-vm-isolation.nix ]; };
     useNixStoreImage = {
       virtualisation = {
-        sharedDirectories = lib.mkForce { };
+        sharedDirectories = pkgs.lib.mkForce { };
         useNixStoreImage = true;
       };
     };