]> git.scottworley.com Git - nixos-qemu-vm-isolation/blobdiff - modules/qemu-vm-isolation.nix
Drop support for < 23.05
[nixos-qemu-vm-isolation] / modules / qemu-vm-isolation.nix
index a9bf0dfc8177d28376c004c3aafd964ec5e19de6..ad586ecc1af14245107efe6db9a83dc7925f4927 100644 (file)
@@ -1,6 +1,6 @@
 { config, lib, modulesPath, pkgs, ... }:
 let
-  inherit (lib) findSingle mkForce mkVMOverride;
+  inherit (lib) findSingle mkForce mkIf mkMerge mkVMOverride;
 
   lookupDriveDeviceName = driveName: driveList:
     (findSingle (drive: drive.name == driveName)
@@ -33,9 +33,6 @@ in {
 
   virtualisation = {
 
-    # This should be the default.
-    bootDevice = lookupDriveDeviceName "root" config.virtualisation.qemu.drives;
-
     sharedDirectories = mkForce { };
 
     qemu.drives = [{