]> git.scottworley.com Git - nixos-qemu-vm-isolation/blobdiff - flake.nix
Use the new nixpkgs.lib.nixos.runTest interface for checks
[nixos-qemu-vm-isolation] / flake.nix
index 757331ddf4927e363eb0b224bdf1e24124b8f3d4..71b4beffc599d0dc052bcc5d7fc7dd1a27cd458e 100644 (file)
--- a/flake.nix
+++ b/flake.nix
@@ -4,7 +4,7 @@
     let
       inherit (nixpkgs.lib) genAttrs;
 
-      systems = nixpkgs.lib.systems.supported.tier1;
+      systems = import ./lib/tier1.nix nixpkgs;
 
       forAllSystems = genAttrs systems;
 
@@ -13,8 +13,8 @@
         qemu-vm-isolation = import ./modules/qemu-vm-isolation.nix;
       };
       checks = forAllSystems (system: {
-        mount-grep = nixpkgs.legacyPackages."${system}".nixosTest
-          (import ./checks/mount-grep.nix);
+        mount-grep = nixpkgs.lib.nixos.runTest
+          (import ./checks/mount-grep.nix nixpkgs.legacyPackages."${system}");
       });
     };
 }