]> git.scottworley.com Git - nixos-qemu-vm-isolation/blobdiff - flake.nix
23.05: New way to get the list of tier1 systems
[nixos-qemu-vm-isolation] / flake.nix
index 355702e731c81ba8b89fc7f5178c22b68522c744..ddce3f9f292a287d3c24b39afd0a56ecee033f7c 100644 (file)
--- a/flake.nix
+++ b/flake.nix
@@ -1,9 +1,10 @@
 {
+  inputs.nixpkgs.url = "github:NixOS/nixpkgs?ref=nixos-unstable";
   outputs = { self, nixpkgs, }:
     let
       inherit (nixpkgs.lib) genAttrs;
 
-      systems = nixpkgs.lib.systems.supported.tier1;
+      systems = import ./lib/tier1.nix nixpkgs;
 
       forAllSystems = genAttrs systems;