1 # Since 168b926435628cb06c4a8cb0f3e6f69f141529f1, we do shenanigans to get the tier1 list. :(
7 inherit (lib) elemAt foldl' isList splitString;
8 inherit (builtins) readFile;
10 lines = splitString "\n";
12 between = start: stop: list:
15 if isNull state && x == start then
17 else if isList state then
18 if x == stop then { result = state; } else state ++ [ x ]
21 in (foldl' step null list).result;
23 strip-quotes = x: elemAt (builtins.match " \"(.*)\"" x) 0;
25 systems-file = "${nixpkgs}/lib/systems/flake-systems.nix";
28 (between " # Tier 1" " # Tier 2" (lines (readFile systems-file)))