+# nix-profile-gc: More gently remove old profiles
+# Copyright (C) 2022 Scott Worley <scottworley@scottworley.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, version 3.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
{ lib, config, pkgs, ... }:
let
inherit (lib) escapeShellArg;
echo "(Disregarding unrelated profile $p)" >&2
continue
fi
- if [[ "$p" == "$current" ]];then
+ pname=$(${pkgs.coreutils}/bin/basename "$p")
+ if [[ "$pname" == "$current" ]];then
echo "Keeeping current profile $p" >&2
continue
fi
echo "Keeeping active system/boot profile $p" >&2
continue
fi
- if [[ "''${active[$p]:-}" ]];then
+ if [[ "''${active[$pname]:-}" ]];then
echo "Keeeping active profile $p" >&2
continue
fi