+# nix-profile-gc: More gently remove old profiles
+# Copyright (C) 2022 Scott Worley <scottworley@scottworley.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, version 3.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
{ lib, config, pkgs, ... }:
let
inherit (lib) escapeShellArg;
dryRun = lib.mkOption {
description = "Say what would have been deleted rather than actually deleting profiles";
type = lib.types.bool;
- default = true;
+ default = false;
};
keepLast = lib.mkOption {
description = ''
fi
alive_threshold="$(< ${parse-duration cfg.activeThreshold})"
- alive_loginterval="$(< ${parse-duration config.systemd.timers.profile-gc-log-active.timerConfig.OnUnitActiveSec})"
+ alive_loginterval="$(< ${parse-duration cfg.activeMeasurementGranularity})"
if (( alive_threshold < alive_loginterval ));then
echo "Liveness threshold is too low. Not doing any profile garbage collection." >&2
exit 0
'';
systemd.timers.profile-gc-log-active = {
wantedBy = [ "timers.target" ];
+ timerConfig.OnActiveSec = cfg.activeMeasurementGranularity;
timerConfig.OnUnitActiveSec = cfg.activeMeasurementGranularity;
};
systemd.services.profile-gc-log-active = {