]> git.scottworley.com Git - nix-profile-gc/blobdiff - modules/profile-gc.nix
Appease shellcheck
[nix-profile-gc] / modules / profile-gc.nix
index a763875d1d3b7a27af05aefc100b93cae6aa2841..6963264ae29d6133623241e49e7a75315fb49ce6 100644 (file)
@@ -1,3 +1,18 @@
+# nix-profile-gc: More gently remove old profiles
+# Copyright (C) 2022 Scott Worley <scottworley@scottworley.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, version 3.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <https://www.gnu.org/licenses/>.
+
 { lib, config, pkgs, ... }:
 let
   inherit (lib) escapeShellArg;
 { lib, config, pkgs, ... }:
 let
   inherit (lib) escapeShellArg;
@@ -14,7 +29,7 @@ in {
       dryRun = lib.mkOption {
         description = "Say what would have been deleted rather than actually deleting profiles";
         type = lib.types.bool;
       dryRun = lib.mkOption {
         description = "Say what would have been deleted rather than actually deleting profiles";
         type = lib.types.bool;
-        default = true;
+        default = false;
       };
       keepLast = lib.mkOption {
         description = ''
       };
       keepLast = lib.mkOption {
         description = ''
@@ -138,7 +153,7 @@ in {
       }
 
       declare -A active_targets
       }
 
       declare -A active_targets
-      while read target;do
+      while read -r target;do
         active_targets[$target]=1
       done < <(
         verbose_topn ${cfg.logdir}/active-system "" ${escapeShellArg cfg.keepLastActiveSystem}
         active_targets[$target]=1
       done < <(
         verbose_topn ${cfg.logdir}/active-system "" ${escapeShellArg cfg.keepLastActiveSystem}
@@ -147,12 +162,12 @@ in {
 
       now=$(${pkgs.coreutils}/bin/date +%s)
       age_threshold="$(< ${parse-duration cfg.keepLatest})"
 
       now=$(${pkgs.coreutils}/bin/date +%s)
       age_threshold="$(< ${parse-duration cfg.keepLatest})"
-      while read profile;do
+      while read -r profile;do
         echo "Contemplating profiles for $profile:" >&2
         unset active
         declare -A active
         echo "Contemplating profiles for $profile:" >&2
         unset active
         declare -A active
-        while read p;do
-          active[$p]=1
+        while read -r pname;do
+          active[$pname]=1
         done < <(verbose_topn ${cfg.logdir}/active-profiles "$profile" ${escapeShellArg cfg.keepLastActive})
         current=$(${pkgs.coreutils}/bin/readlink "$profile")
         currentgen=''${current%-link}
         done < <(verbose_topn ${cfg.logdir}/active-profiles "$profile" ${escapeShellArg cfg.keepLastActive})
         current=$(${pkgs.coreutils}/bin/readlink "$profile")
         currentgen=''${current%-link}
@@ -164,7 +179,8 @@ in {
             echo "(Disregarding unrelated profile $p)" >&2
             continue
           fi
             echo "(Disregarding unrelated profile $p)" >&2
             continue
           fi
-          if [[ "$p" == "$current" ]];then
+          pname=$(${pkgs.coreutils}/bin/basename "$p")
+          if [[ "$pname" == "$current" ]];then
             echo "Keeeping current profile $p" >&2
             continue
           fi
             echo "Keeeping current profile $p" >&2
             continue
           fi
@@ -172,7 +188,7 @@ in {
             echo "Keeeping active system/boot profile $p" >&2
             continue
           fi
             echo "Keeeping active system/boot profile $p" >&2
             continue
           fi
-          if [[ "''${active[$p]:-}" ]];then
+          if [[ "''${active[$pname]:-}" ]];then
             echo "Keeeping active profile $p" >&2
             continue
           fi
             echo "Keeeping active profile $p" >&2
             continue
           fi
@@ -193,7 +209,7 @@ in {
             rm "$p"
           ''}
         done
             rm "$p"
           ''}
         done
-      done < <(${pkgs.findutils}/bin/find ''${NIX_STATE_DIR:-/nix/var/nix}/profiles/ -type l -not -name '*[0-9]-link')
+      done < <(${pkgs.findutils}/bin/find "''${NIX_STATE_DIR:-/nix/var/nix}/profiles/" -type l -not -name '*[0-9]-link')
     '';
     systemd.timers.profile-gc-log-active = {
       wantedBy = [ "timers.target" ];
     '';
     systemd.timers.profile-gc-log-active = {
       wantedBy = [ "timers.target" ];