echo "Keeeping current profile $p" >&2
continue
fi
- if [[ "''${active_targets[$(${pkgs.coreutils}/bin/readlink "$p")]}" ]];then
+ if [[ "''${active_targets[$(${pkgs.coreutils}/bin/readlink "$p")]:-}" ]];then
echo "Keeeping active system/boot profile $p" >&2
continue
fi
- if [[ "''${active[$p]}" ]];then
+ if [[ "''${active[$p]:-}" ]];then
echo "Keeeping active profile $p" >&2
continue
fi