]> git.scottworley.com Git - nix-profile-gc/blobdiff - modules/profile-gc.nix
profile-gc: Make activeMeasurementGranularity configurable
[nix-profile-gc] / modules / profile-gc.nix
index 8e693010f647c09d4849f16f515c7ba2b9e6b300..ba2821a8fc599e45397c6550c59cb547283d550f 100644 (file)
@@ -49,16 +49,23 @@ in {
           awhile (so keepLatest won't protect them) generates a bunch of broken profiles (so
           keepLast won't protect them) while trying to get up to date.
 
           awhile (so keepLatest won't protect them) generates a bunch of broken profiles (so
           keepLast won't protect them) while trying to get up to date.
 
-          This is approximate and has a useful granularity of an hour
-          (config.systemd.timers.profile-gc-log-active.timerConfig.OnUnitActiveSec).
-          Do not set less than this.
+          This threshold is approximate, see activeMeasurementGranularity.
+          Do not set less than activeMeasurementGranularity!
         '';
         '';
-        # We admonish the user "Do not set less than this." and check it at runtime rather
-        # than verifying this with an assertion now because parsing these durations at
-        # configuration-time requires import-from-derivation, which we want to avoid.  :(
+        # We admonish the user "Do not set less than activeMeasurementGranularity!" and check
+        # it at runtime rather than verifying this with an assertion at evaluation time because
+        # parsing these durations at evaluation-time requires import-from-derivation, which we
+        # want to avoid.  :(
         type = lib.types.str;
         default = "5 days";
       };
         type = lib.types.str;
         default = "5 days";
       };
+      activeMeasurementGranularity = lib.mkOption {
+        description = ''
+          How often to make a note of the currently-active profiles.  This is the useful
+          granularity and minimum value of activeThreshold.
+        '';
+        default = "1 hour";
+      };
       keepLatest = lib.mkOption {
         description = ''
           Keep all profiles younger than this duration (systemd.time format).
       keepLatest = lib.mkOption {
         description = ''
           Keep all profiles younger than this duration (systemd.time format).
@@ -161,11 +168,11 @@ in {
             echo "Keeeping current profile $p" >&2
             continue
           fi
             echo "Keeeping current profile $p" >&2
             continue
           fi
-          if [[ "''${active_targets[$(${pkgs.coreutils}/bin/readlink "$p")]}" ]];then
+          if [[ "''${active_targets[$(${pkgs.coreutils}/bin/readlink "$p")]:-}" ]];then
             echo "Keeeping active system/boot profile $p" >&2
             continue
           fi
             echo "Keeeping active system/boot profile $p" >&2
             continue
           fi
-          if [[ "''${active[$p]}" ]];then
+          if [[ "''${active[$p]:-}" ]];then
             echo "Keeeping active profile $p" >&2
             continue
           fi
             echo "Keeeping active profile $p" >&2
             continue
           fi
@@ -190,7 +197,7 @@ in {
     '';
     systemd.timers.profile-gc-log-active = {
       wantedBy = [ "timers.target" ];
     '';
     systemd.timers.profile-gc-log-active = {
       wantedBy = [ "timers.target" ];
-      timerConfig.OnUnitActiveSec = "1 hour";
+      timerConfig.OnUnitActiveSec = cfg.activeMeasurementGranularity;
     };
     systemd.services.profile-gc-log-active = {
       description =
     };
     systemd.services.profile-gc-log-active = {
       description =