]> git.scottworley.com Git - nix-pin-deps/blobdiff - default.nix
Release 1.1.0
[nix-pin-deps] / default.nix
index 7be4d9c69affbb793032affdc3d2a372febd6520..9beabfb59628ce41ae14b47f16bbf5977bffae31 100644 (file)
@@ -3,11 +3,17 @@ pkgs.python3Packages.callPackage
 ({ lib, buildPythonPackage, autopep8, mypy, pylint, }:
   buildPythonPackage rec {
     pname = "nix-pin-deps";
-    version = "1.0.0";
+    version = "1.1.0";
     src = lib.cleanSource ./.;
-    checkInputs = [ mypy ] ++ lib.optionals lint [ autopep8 pylint ];
+    nativeCheckInputs = [ mypy ] ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = ''
       ./test.sh ${lib.optionalString lint "lint"}
     '';
+    meta = {
+      description = "GC-pin dependencies of a partially-built derivation";
+      homepage = "https://git.scottworley.com/nix-pin-deps";
+      license = pkgs.lib.licenses.gpl3;
+      maintainers = with pkgs.lib.maintainers; [ chkno ];
+    };
   }) { }