pname = "nix-pin-deps";
version = "1.0.0";
src = lib.cleanSource ./.;
- checkInputs = [ mypy ] ++ lib.optionals lint [ autopep8 pylint ];
+ nativeCheckInputs = [ mypy ] ++ lib.optionals lint [ autopep8 pylint ];
doCheck = true;
checkPhase = ''
./test.sh ${lib.optionalString lint "lint"}
'';
+ meta = {
+ description = "GC-pin dependencies of a partially-built derivation";
+ homepage = "https://git.scottworley.com/nix-pin-deps";
+ license = pkgs.lib.licenses.gpl3;
+ maintainers = with pkgs.lib.maintainers; [ chkno ];
+ };
}) { }