]> git.scottworley.com Git - git-cache/blobdiff - default.nix
Specify license
[git-cache] / default.nix
index 6c57b0d389bd9f9d1ae2c26ee2232b0ec5851078..a161d41c6c6dd5debbdfea977f105caa4b459a05 100644 (file)
@@ -1,11 +1,19 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
+
 pkgs.python3Packages.callPackage
-({ lib, buildPythonPackage, nix, git, autopep8, mypy, pylint, }:
+({ lib, buildPythonPackage, nix, git, backoff, autopep8, mypy, pylint, }:
   buildPythonPackage rec {
     pname = "git-cache";
-    version = "1.2.0-pre";
+    version = "1.4.2";
     src = lib.cleanSource ./.;
+    propagatedBuildInputs = [ backoff ];
     checkInputs = [ nix git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";
+    meta = {
+      description = "Cache git content locally";
+      homepage = "https://git.scottworley.com/git-cache";
+      license = pkgs.lib.licenses.gpl3;
+      maintainers = with pkgs.lib.maintainers; [ chkno ];
+    };
   }) { }