]> git.scottworley.com Git - git-cache/blobdiff - default.nix
Rely on nixpkgs' python3Packages.backoff
[git-cache] / default.nix
index 918c9ec7c74b47bf109e209faad5f57494e6c418..9b932fb14518bd6f653300a76aa26b43e210fb2b 100644 (file)
@@ -1,24 +1,6 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
 
-let
-  # Remove this package definition after https://github.com/NixOS/nixpkgs/pull/93377 reaches stable
-  backoff-fallback = { lib, buildPythonPackage, fetchPypi }:
-    buildPythonPackage rec {
-      pname = "backoff";
-      version = "1.10.0";
-      src = fetchPypi {
-        inherit pname version;
-        sha256 = "190rdpfhpjvb6bjh99fhdkgfsfkjwky7nz7b0nn5ah67z8hs1yxq";
-      };
-      meta = with lib; {
-        description = "Function decoration for backoff and retry";
-        homepage = "https://github.com/litl/backoff";
-        license = licenses.mit;
-        maintainers = with maintainers; [ chkno ];
-      };
-    };
-
-in pkgs.python3Packages.callPackage
+pkgs.python3Packages.callPackage
 ({ lib, buildPythonPackage, nix, git, backoff, autopep8, mypy, pylint, }:
   buildPythonPackage rec {
     pname = "git-cache";
@@ -28,7 +10,4 @@ in pkgs.python3Packages.callPackage
     checkInputs = [ nix git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";
-  }) {
-    backoff = pkgs.python3Packages.backoff or (pkgs.python3Packages.callPackage
-      backoff-fallback { });
-  }
+  }) { }