((import (nixpkgs + "/pkgs/top-level/release.nix")
{ }).stdenvBootstrapTools));
+ in {
+
+ overlay = final: prev: { git-cache = import ./. { pkgs = final; }; };
+ overlays = { git-cache = self.overlay; };
+
packages = for-supported-systems (system: {
inherit (nixpkgs.legacyPackages."${system}".appendOverlays
[ self.overlay ])
git-cache;
});
- in {
- inherit packages;
-
- overlay = final: prev: { git-cache = import ./. { pkgs = final; }; };
- overlays = { git-cache = self.overlay; };
-
defaultApp = for-supported-systems (system: {
type = "app";
- program = "${packages."${system}".git-cache}/bin/git-cache";
+ program = "${self.packages."${system}".git-cache}/bin/git-cache";
});
};
}