]> git.scottworley.com Git - git-cache/blobdiff - default.nix
Adapt to nixpkgs' nativeCheckInputs change
[git-cache] / default.nix
index a161d41c6c6dd5debbdfea977f105caa4b459a05..d2337001f358cca6a852fa39f7b5452404d3bed1 100644 (file)
@@ -1,13 +1,19 @@
 { pkgs ? import <nixpkgs> { }, lint ? false }:
 
-pkgs.python3Packages.callPackage
+let
+  checkInputsAreNative = pkgs.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
+in pkgs.python3Packages.callPackage
 ({ lib, buildPythonPackage, nix, git, backoff, autopep8, mypy, pylint, }:
   buildPythonPackage rec {
     pname = "git-cache";
     version = "1.4.2";
     src = lib.cleanSource ./.;
     propagatedBuildInputs = [ backoff ];
-    checkInputs = [ nix git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
+    "${checkInputsName}" = [ nix git mypy ]
+      ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";
     meta = {