]> git.scottworley.com Git - git-cache/blobdiff - flake.nix
Start on 1.4.2
[git-cache] / flake.nix
index 49594a700f0186be3be5525cf4610dc07ed00f5b..4be7c77c6c506f3c4d2c900c63444dd6e45f3a7d 100644 (file)
--- a/flake.nix
+++ b/flake.nix
         ((import (nixpkgs + "/pkgs/top-level/release.nix")
           { }).stdenvBootstrapTools));
 
+    in {
+
+      overlay = final: prev: { git-cache = import ./. { pkgs = final; }; };
+      overlays = { git-cache = self.overlay; };
+
       packages = for-supported-systems (system: {
-        git-cache = import ./. { pkgs = nixpkgs.legacyPackages."${system}"; };
+        inherit (nixpkgs.legacyPackages."${system}".appendOverlays
+          [ self.overlay ])
+          git-cache;
       });
 
-    in {
-      inherit packages;
-
       defaultApp = for-supported-systems (system: {
         type = "app";
-        program = "${packages."${system}".git-cache}/bin/git-cache";
+        program = "${self.packages."${system}".git-cache}/bin/git-cache";
       });
     };
 }