({ lib, buildPythonPackage, nix, git, backoff, autopep8, mypy, pylint, }:
buildPythonPackage rec {
pname = "git-cache";
- version = "1.4.2-pre";
+ version = "1.4.2";
src = lib.cleanSource ./.;
propagatedBuildInputs = [ backoff ];
checkInputs = [ nix git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
doCheck = true;
checkPhase = "./test.sh";
+ meta = {
+ description = "Cache git content locally";
+ homepage = "https://git.scottworley.com/git-cache";
+ license = pkgs.lib.licenses.gpl3;
+ maintainers = with pkgs.lib.maintainers; [ chkno ];
+ };
}) { }