]> git.scottworley.com Git - git-cache/blobdiff - default.nix
Specify license
[git-cache] / default.nix
index 9b932fb14518bd6f653300a76aa26b43e210fb2b..a161d41c6c6dd5debbdfea977f105caa4b459a05 100644 (file)
@@ -4,10 +4,16 @@ pkgs.python3Packages.callPackage
 ({ lib, buildPythonPackage, nix, git, backoff, autopep8, mypy, pylint, }:
   buildPythonPackage rec {
     pname = "git-cache";
 ({ lib, buildPythonPackage, nix, git, backoff, autopep8, mypy, pylint, }:
   buildPythonPackage rec {
     pname = "git-cache";
-    version = "1.4.2-pre";
+    version = "1.4.2";
     src = lib.cleanSource ./.;
     propagatedBuildInputs = [ backoff ];
     checkInputs = [ nix git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";
     src = lib.cleanSource ./.;
     propagatedBuildInputs = [ backoff ];
     checkInputs = [ nix git mypy ] ++ lib.optionals lint [ autopep8 pylint ];
     doCheck = true;
     checkPhase = "./test.sh";
+    meta = {
+      description = "Cache git content locally";
+      homepage = "https://git.scottworley.com/git-cache";
+      license = pkgs.lib.licenses.gpl3;
+      maintainers = with pkgs.lib.maintainers; [ chkno ];
+    };
   }) { }
   }) { }