]> git.scottworley.com Git - git-cache/blobdiff - flake.nix
Offer "overlay" and "overlays" flake outputs
[git-cache] / flake.nix
index 49594a700f0186be3be5525cf4610dc07ed00f5b..195cc33dac3dddd620869ba68e8e84c96d2a3354 100644 (file)
--- a/flake.nix
+++ b/flake.nix
           { }).stdenvBootstrapTools));
 
       packages = for-supported-systems (system: {
-        git-cache = import ./. { pkgs = nixpkgs.legacyPackages."${system}"; };
+        inherit (nixpkgs.legacyPackages."${system}".appendOverlays
+          [ self.overlay ])
+          git-cache;
       });
 
     in {
       inherit packages;
 
+      overlay = final: prev: { git-cache = import ./. { pkgs = final; }; };
+      overlays = { git-cache = self.overlay; };
+
       defaultApp = for-supported-systems (system: {
         type = "app";
         program = "${packages."${system}".git-cache}/bin/git-cache";