]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - modules/auto-upgrade.nix
Separate pull-updates snippet
[auto-upgrade-with-pinch] / modules / auto-upgrade.nix
index aabb0e2dcc4c6a530e9f9b40b2f456a797bb4143..d30a624b9e567d7a7d9397d6c0d1791abf33dfe4 100644 (file)
@@ -2,6 +2,15 @@
 with lib;
 let
   cfg = config.system.autoUpgradeWithPinch;
+  pull-repo-snippet = ''
+    (
+      cd /etc/nixos
+      ${pkgs.git}/bin/git fetch
+      PATH="${pkgs.keyedgit cfg.keys}/bin:$PATH" \
+        ${pkgs.polite-merge}/bin/polite-merge --ff-only --verify-signatures
+    )
+  '';
+
   auto-upgrade-script = pkgs.writeShellScript "auto-upgrade" ''
     ${pkgs.utillinux}/bin/flock /run/auto-upgrade-with-pinch ${
       pkgs.writeShellScript "auto-upgrade-with-lock-held" ''
@@ -25,12 +34,8 @@ let
           }
         }
 
-        # Fetch updates
-        (
-          cd /etc/nixos
-          ${pkgs.git}/bin/git fetch
-          PATH="${pkgs.keyedgit cfg.keys}/bin:$PATH" ${pkgs.polite-merge}/bin/polite-merge --ff-only --verify-signatures
-        )
+        # Pull updates
+        ${pull-repo-snippet}
 
         # Update channels
         ${pkgs.pinch}/bin/pinch update /etc/nixos/channels