]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - upgrade-config.nix
git-cache: 1.3.1 → 1.4.2
[auto-upgrade-with-pinch] / upgrade-config.nix
index e9962ebbee18662ac1fd902ffd71e3f466cc7c92..67c4ec1d5a4fc56b13ca03b44063cc2c22cbcd3a 100644 (file)
@@ -33,6 +33,7 @@ evalModules {
           can use them both as points of intervention in the automation and to
           author and push changes back up.
         '';
+        default = { };
         type = types.attrsOf (types.submodule {
           options = {
             url = mkOption {
@@ -84,14 +85,6 @@ evalModules {
                 specifed in <literal>signingKeys</literal>.
               '';
             };
-            signingKeys = mkOption {
-              type = types.listOf types.path;
-              description = ''
-                Files containing GPG keys that are authorized to sign updates.
-                Updates are only merged if the commit at the tip of the remote
-                ref is signed with one of these keys.
-              '';
-            };
           };
         });
         example = {
@@ -114,6 +107,7 @@ evalModules {
           <literal>repos</literal>' paths.
         '';
         type = types.listOf types.path;
+        default = [ ];
         example = [ "/etc/nixos/channels" ];
       };
 
@@ -121,6 +115,7 @@ evalModules {
         description = ''
           User environments to update as part of an upgrade run.
         '';
+        default = { };
         type = types.attrsOf (types.submodule {
           options = {
             package = mkOption {