can use them both as points of intervention in the automation and to
author and push changes back up.
'';
+ default = { };
type = types.attrsOf (types.submodule {
options = {
url = mkOption {
specifed in <literal>signingKeys</literal>.
'';
};
- signingKeys = mkOption {
- type = types.listOf types.path;
- description = ''
- Files containing GPG keys that are authorized to sign updates.
- Updates are only merged if the commit at the tip of the remote
- ref is signed with one of these keys.
- '';
- };
};
});
example = {
<literal>repos</literal>' paths.
'';
type = types.listOf types.path;
+ default = [ ];
example = [ "/etc/nixos/channels" ];
};
description = ''
User environments to update as part of an upgrade run.
'';
+ default = { };
type = types.attrsOf (types.submodule {
options = {
package = mkOption {