]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - default.nix
Use local pkgs instead of overlays
[auto-upgrade-with-pinch] / default.nix
index 8dd9a56fb06a7cf1aec68e6d624d3c36179697f5..1413fef74a3415f38f53b3b8035e679dc207ad02 100644 (file)
@@ -1,5 +1,10 @@
-# When installed as a channel, this is not an environment.
-#
-# This file exists to stop getAllExprs() in nix/src/nix-env/nix-env.cc from recursing around in here and getting confused.
+{ pkgs ? import <nixpkgs> { }, }:
 
-{}
+pkgs.lib.makeScope pkgs.newScope (self:
+  with self; {
+
+    homeless-gpg = callPackage ./pkgs/homeless-gpg.nix { };
+
+    keyed-gpg = callPackage ./pkgs/keyed-gpg.nix { };
+
+  })