]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - modules/auto-upgrade.nix
Only add pinch if not already present
[auto-upgrade-with-pinch] / modules / auto-upgrade.nix
index 216c4baf8fa624e4d2ed08680c21edfa0ccd27d4..9ff5ee2e9da2b062ac21e500c02ea468a9ad278a 100644 (file)
@@ -3,7 +3,7 @@ with lib;
 let
   cfg = config.system.autoUpgradeWithPinch;
   auto-upgrade-script = pkgs.writeShellScript "auto-upgrade" ''
-    flock /run/auto-upgrade-with-pinch ${
+    ${pkgs.utillinux}/bin/flock /run/auto-upgrade-with-pinch ${
       pkgs.writeShellScript "auto-upgrade-with-lock-held" ''
         set -e
 
@@ -34,7 +34,7 @@ let
 
         # Build
         in_tmpdir ${config.system.build.nixos-rebuild}/bin/nixos-rebuild build
-        as_user nix-build '<nixpkgs>' -A ${
+        as_user nix-build --no-out-link '<nixpkgs>' -A ${
           escapeShellArg cfg.userEnvironment.package
         }