({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
buildPythonPackage rec {
pname = "git-cache";
- version = "1.3.0";
+ version = "1.3.1";
src = fetchgit {
- url = "https://scottworley.com/git-cache.git";
+ url = "https://git.scottworley.com/pub/git/git-cache";
rev = "v${version}";
- sha256 = "sha256-0HbtnS98im0sd2JIdUePBcspUskL2DY8ylQdyEC2sS0=";
+ sha256 = "0awz7f6avzw9fk9gp1kadj0nbmf1s60qic9zb6ww92zig3khg12k";
};
propagatedBuildInputs = [ backoff ];
checkInputs = [ git mypy ];
}) { backoff = self.python3Packages.backoff or fallback-backoff; };
fallback-pinch = self.python3Packages.callPackage
- ({ buildPythonPackage, fetchgit, nix, git, makeWrapper, mypy, git-cache, }:
+ ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
buildPythonPackage rec {
pname = "pinch";
- version = "3.0.4";
+ version = "3.0.9";
src = fetchgit {
- url = "https://scottworley.com/pinch.git";
+ url = "https://git.scottworley.com/pub/git/pinch";
rev = "v${version}";
- sha256 = "1i7v9vcjk599ffzwf3nq38y811cm6rnxriarqgpp3kwy52r91mi2";
+ sha256 = "sha256-D1XC8pmemdOpIEWvS0VH9Fguvp92FqpQfJj2TudfwRw=";
};
buildInputs = [ makeWrapper ];
propagatedBuildInputs = [ git-cache ];
- checkInputs = [ nix git mypy ];
+ checkInputs = [ nix_2_3 git mypy ];
postInstall = ''
- wrapProgram "$out/bin/pinch" --prefix PATH : ${nix}/bin
+ wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
'';
doCheck = true;
checkPhase = "./test.sh";