]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/polite-merge.nix
Adapt to nixpkgs' nativeCheckInputs change
[auto-upgrade-with-pinch] / overlays / polite-merge.nix
index bc73b15dd5120ab79df9d97546490503108cef79..37f7ba54aab8f3084c722e26f087291f6d926bfa 100644 (file)
@@ -1,4 +1,10 @@
-self: super: {
+self: super:
+let
+  checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
+in {
   polite-merge = if builtins.hasAttr "polite-merge" super then
     super.polite-merge
   else
@@ -12,7 +18,7 @@ self: super: {
           sha256 = "1p6ivaay3bk4vvqqic7g23xrhkkq8z19zhsaxkav8kk90s2bmmza";
         };
         postUnpack = "patchShebangs .";
-        checkInputs = [ git ];
+        "${checkInputsName}" = [ git ];
         doCheck = true;
         preInstall = "export prefix";
       }) { };