]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/pinch.nix
Adapt to nixpkgs' nativeCheckInputs change
[auto-upgrade-with-pinch] / overlays / pinch.nix
index dfb9eaca3b737001867c477c22a10268a2ff1bd7..07daaf7321156f4f2efa04eb1a317c9ad6200672 100644 (file)
@@ -1,5 +1,9 @@
 self: super:
 let
+  checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
 
   fallback-git-cache = self.python3Packages.callPackage
     ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
@@ -12,7 +16,7 @@ let
           hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
         };
         propagatedBuildInputs = [ backoff ];
-        checkInputs = [ git mypy ];
+        "${checkInputsName}" = [ git mypy ];
         doCheck = true;
         checkPhase = "./test.sh";
       }) { };
@@ -29,7 +33,7 @@ let
         };
         buildInputs = [ makeWrapper ];
         propagatedBuildInputs = [ git-cache ];
-        checkInputs = [ nix_2_3 git mypy ];
+        "${checkInputsName}" = [ nix_2_3 git mypy ];
         postInstall = ''
           wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
         '';