self: super:
let
+ checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+ (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+ checkInputsName =
+ if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
fallback-git-cache = self.python3Packages.callPackage
({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
};
propagatedBuildInputs = [ backoff ];
- checkInputs = [ git mypy ];
+ "${checkInputsName}" = [ git mypy ];
doCheck = true;
checkPhase = "./test.sh";
}) { };
};
buildInputs = [ makeWrapper ];
propagatedBuildInputs = [ git-cache ];
- checkInputs = [ nix_2_3 git mypy ];
+ "${checkInputsName}" = [ nix_2_3 git mypy ];
postInstall = ''
wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
'';