]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/pinch.nix
pinch: 3.0.15 → 3.1.0 for "git_ref = tag <tag>" support
[auto-upgrade-with-pinch] / overlays / pinch.nix
index 0dad303f43242c049b5c3f4af50bfec1047348db..37c2e7d079f7ea1816b53c59a815e09403f85c43 100644 (file)
@@ -1,19 +1,44 @@
-self: super: {
-  pinch = if builtins.hasAttr "pinch" super then
-    super.pinch
-  else
-    self.python3Packages.callPackage
-    ({ buildPythonPackage, fetchgit, nix, git, mypy, }:
+self: super:
+let
+  checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
+
+  fallback-git-cache = self.python3Packages.callPackage
+    ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
       buildPythonPackage rec {
-        pname = "pinch";
-        version = "1.5";
+        pname = "git-cache";
+        version = "1.5.0";
         src = fetchgit {
-          url = "https://scottworley.com/pinch.git";
-          rev = version;
-          sha256 = "0si7z78iy8b5dfjs8ijy8bq9fwcfq51syqxijkc6mg5m7awwsf3l";
+          url = "https://git.scottworley.com/pub/git/git-cache";
+          rev = "v${version}";
+          hash = "sha256-g4TS/zX3e29Q3ThsCAX2wLLlYbi8fdux5uqAc+b/Oww=";
         };
-        checkInputs = [ nix git mypy ];
+        propagatedBuildInputs = [ backoff ];
+        "${checkInputsName}" = [ git mypy ];
         doCheck = true;
         checkPhase = "./test.sh";
       }) { };
-}
+
+  fallback-pinch = self.python3Packages.callPackage
+    ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
+      buildPythonPackage rec {
+        pname = "pinch";
+        version = "3.1.0";
+        src = fetchgit {
+          url = "https://git.scottworley.com/pub/git/pinch";
+          rev = "v${version}";
+          hash = "sha256-qwbYDSGE6p1YU3AnOatXNoTUc284D1xPQs/tRS++VOM=";
+        };
+        buildInputs = [ makeWrapper ];
+        propagatedBuildInputs = [ git-cache ];
+        "${checkInputsName}" = [ nix_2_3 git mypy ];
+        postInstall = ''
+          wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
+        '';
+        doCheck = true;
+        checkPhase = "./test.sh";
+      }) { git-cache = self.python3Packages.git-cache or fallback-git-cache; };
+
+in { pinch = super.pinch or fallback-pinch; }