]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/pinch.nix
When becoming other users, cd to /
[auto-upgrade-with-pinch] / overlays / pinch.nix
index 37c2e7d079f7ea1816b53c59a815e09403f85c43..8e9633f89cf6a5c9f0cebc6046a51102253b39fb 100644 (file)
@@ -1,10 +1,5 @@
 self: super:
 let
-  checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
-    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
-  checkInputsName =
-    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
-
   fallback-git-cache = self.python3Packages.callPackage
     ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
       buildPythonPackage rec {
@@ -16,7 +11,7 @@ let
           hash = "sha256-g4TS/zX3e29Q3ThsCAX2wLLlYbi8fdux5uqAc+b/Oww=";
         };
         propagatedBuildInputs = [ backoff ];
-        "${checkInputsName}" = [ git mypy ];
+        nativeCheckInputs = [ git mypy ];
         doCheck = true;
         checkPhase = "./test.sh";
       }) { };
@@ -33,7 +28,7 @@ let
         };
         buildInputs = [ makeWrapper ];
         propagatedBuildInputs = [ git-cache ];
-        "${checkInputsName}" = [ nix_2_3 git mypy ];
+        nativeCheckInputs = [ nix_2_3 git mypy ];
         postInstall = ''
           wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
         '';