-self: super: {
+self: super:
+let
+ checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+ (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+ checkInputsName =
+ if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
+in {
polite-merge = if builtins.hasAttr "polite-merge" super then
super.polite-merge
else
sha256 = "1p6ivaay3bk4vvqqic7g23xrhkkq8z19zhsaxkav8kk90s2bmmza";
};
postUnpack = "patchShebangs .";
- checkInputs = [ git ];
+ "${checkInputsName}" = [ git ];
doCheck = true;
preInstall = "export prefix";
}) { };