]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/keyedgit.nix
Specify key by long key id, not fingerprint
[auto-upgrade-with-pinch] / overlays / keyedgit.nix
index a4465dcf493328d12f3b53b33b5f18ecfa8de3ff..7688acefb3f0e9e2abdb49905801380f7d106755 100644 (file)
@@ -13,7 +13,7 @@ self: super: {
       '';
       keyids = super.runCommand "keyids" {} ''
         ${homelessGPG} --no-default-keyring --with-colons --show-keys ${keys} |
-          ${self.gawk}/bin/awk -F: 'prev == "pub" && $1 == "fpr" { print $10 } { prev = $1 }' > $out
+          ${self.gawk}/bin/awk -F: '$1 == "pub" { print $5 }' > $out
       '';
       keyedGPG = super.writeShellScript "keyed-gpg" ''
         trusted_key_args=()