+ # Chill for awhile before applying updates. If applying an update
+ # badly breaks things, we want a window in which an operator can
+ # intervene either to fix the problem or disable automatic updates.
+ sleep 2h
+
+ # Wait until outside business hours
+ now=$(date +%s)
+ day_of_week=$(date +%u)
+ business_start=$(date -d 8:00 +%s)
+ business_end=$( date -d 17:00 +%s)
+ if (( day_of_week <= 5 && now > business_start && now < business_end ));then
+ delay=$((business_end - now))
+ echo "Waiting $delay seconds so we don't upgrade during business hours" >&2
+ sleep "$delay"
+ fi
+
+ ${pkgs.auto-upgrade}/bin/auto-upgrade