]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - modules/auto-upgrade.nix
Safety-hatch: Initial delay
[auto-upgrade-with-pinch] / modules / auto-upgrade.nix
index 973ac2268aff6e9b2b108d24eb5582984a79adb2..b493ac00d0db5478fe782ce065a934962779bb47 100644 (file)
@@ -25,11 +25,22 @@ in {
           which the update will occur.
         '';
       };
+
+      key = mkOption {
+        type = types.path;
+        description = ''
+          GPG key that signs updates.  Updates are only merged if the commit
+          at the tip of the remote branch is signed with this key.
+        '';
+      };
     };
   };
 
   config = lib.mkIf cfg.enable {
-    nixpkgs.overlays = [ (import ../overlays/pinch.nix) ];
+    nixpkgs.overlays = [
+      (import ../overlays/keyedgit.nix)
+      (import ../overlays/pinch.nix)
+    ];
     systemd.services.nixos-upgrade = {
       description = "NixOS Upgrade";
       restartIfChanged = false;
@@ -53,9 +64,15 @@ in {
 
       script = ''
         set -e
+
+        # Chill for awhile before applying updates.  If applying an update
+        # badly breaks things, we want a window in which an operator can
+        # intervene either to fix the problem or disable automatic updates.
+        sleep 2h
+
         (
           cd /etc/nixos
-          git pull --ff-only
+          ${pkgs.keyedgit cfg.key}/bin/git pull --ff-only --verify-signatures
           pinch update channels
         )