]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/pinch.nix
When becoming other users, cd to / with pushd, not sudo -D
[auto-upgrade-with-pinch] / overlays / pinch.nix
index 7dcddb06546f07b6f91b20c9723bb346b935ebbc..8e9633f89cf6a5c9f0cebc6046a51102253b39fb 100644 (file)
@@ -1,22 +1,17 @@
 self: super:
 let
-  checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
-    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
-  checkInputsName =
-    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
-
   fallback-git-cache = self.python3Packages.callPackage
     ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
       buildPythonPackage rec {
         pname = "git-cache";
-        version = "1.4.3";
+        version = "1.5.0";
         src = fetchgit {
           url = "https://git.scottworley.com/pub/git/git-cache";
           rev = "v${version}";
-          hash = "sha256-Qr62bGdlFFkzYTl6ot34UiOJxbP1Eeelx2OEd96vrqI=";
+          hash = "sha256-g4TS/zX3e29Q3ThsCAX2wLLlYbi8fdux5uqAc+b/Oww=";
         };
         propagatedBuildInputs = [ backoff ];
-        "${checkInputsName}" = [ git mypy ];
+        nativeCheckInputs = [ git mypy ];
         doCheck = true;
         checkPhase = "./test.sh";
       }) { };
@@ -25,15 +20,15 @@ let
     ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
       buildPythonPackage rec {
         pname = "pinch";
-        version = "3.0.10";
+        version = "3.1.0";
         src = fetchgit {
           url = "https://git.scottworley.com/pub/git/pinch";
           rev = "v${version}";
-          hash = "sha256-U3TOTfYvM1ONF9DJrWxfhjVQnY7GD96ru6A2Yj01lcg=";
+          hash = "sha256-qwbYDSGE6p1YU3AnOatXNoTUc284D1xPQs/tRS++VOM=";
         };
         buildInputs = [ makeWrapper ];
         propagatedBuildInputs = [ git-cache ];
-        "${checkInputsName}" = [ nix_2_3 git mypy ];
+        nativeCheckInputs = [ nix_2_3 git mypy ];
         postInstall = ''
           wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
         '';