self: super:
let
- # Pending upstream inclusion in https://github.com/NixOS/nixpkgs/pull/93377
- fallback-backoff = self.python3Packages.callPackage ({ lib, buildPythonPackage
- , fetchFromGitHub, pytestCheckHook, poetry, pytest-asyncio, }:
- buildPythonPackage rec {
- pname = "backoff";
- version = "1.10.0";
- src = fetchFromGitHub {
- owner = "litl";
- repo = pname;
- rev = "v${version}";
- sha256 = "1jj0l6pjx747d2yyvnzd3qbm4qr73sq6cc56dhvd8wqfbp5279x0";
- };
- format = "pyproject";
- nativeBuildInputs = [ poetry ];
- checkInputs = [ pytestCheckHook pytest-asyncio ];
- }) { };
-
fallback-git-cache = self.python3Packages.callPackage
({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
buildPythonPackage rec {
checkInputs = [ git mypy ];
doCheck = true;
checkPhase = "./test.sh";
- }) { backoff = self.python3Packages.backoff or fallback-backoff; };
+ }) { };
fallback-pinch = self.python3Packages.callPackage
({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }: