]> git.scottworley.com Git - auto-upgrade-with-pinch/blobdiff - overlays/pinch.nix
pinch: 3.0.11 → 3.0.12
[auto-upgrade-with-pinch] / overlays / pinch.nix
index 12751ec5737fd860b1e781294fd0d90d8356e6b8..72fd8b6f191e04a3756925da174625c907bcee87 100644 (file)
@@ -1,18 +1,22 @@
 self: super:
 let
+  checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+    (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+  checkInputsName =
+    if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
 
   fallback-git-cache = self.python3Packages.callPackage
     ({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
       buildPythonPackage rec {
         pname = "git-cache";
-        version = "1.4.2";
+        version = "1.4.3";
         src = fetchgit {
           url = "https://git.scottworley.com/pub/git/git-cache";
           rev = "v${version}";
-          hash = "sha256-Z9daNCmjzaVdeG3mITRWdNM+ewUEcKy5N4/Xpdotsg0=";
+          hash = "sha256-Qr62bGdlFFkzYTl6ot34UiOJxbP1Eeelx2OEd96vrqI=";
         };
         propagatedBuildInputs = [ backoff ];
-        checkInputs = [ git mypy ];
+        "${checkInputsName}" = [ git mypy ];
         doCheck = true;
         checkPhase = "./test.sh";
       }) { };
@@ -21,15 +25,15 @@ let
     ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
       buildPythonPackage rec {
         pname = "pinch";
-        version = "3.0.9";
+        version = "3.0.12";
         src = fetchgit {
           url = "https://git.scottworley.com/pub/git/pinch";
           rev = "v${version}";
-          sha256 = "sha256-D1XC8pmemdOpIEWvS0VH9Fguvp92FqpQfJj2TudfwRw=";
+          hash = "sha256-1fsTPEDOidGI0IJMelZW4FB1VOP8RT+GSbDoL2vNUJY=";
         };
         buildInputs = [ makeWrapper ];
         propagatedBuildInputs = [ git-cache ];
-        checkInputs = [ nix_2_3 git mypy ];
+        "${checkInputsName}" = [ nix_2_3 git mypy ];
         postInstall = ''
           wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
         '';