can use them both as points of intervention in the automation and to
author and push changes back up.
'';
+ default = { };
type = types.attrsOf (types.submodule {
options = {
url = mkOption {
<literal>repos</literal>' paths.
'';
type = types.listOf types.path;
+ default = [ ];
example = [ "/etc/nixos/channels" ];
};
description = ''
User environments to update as part of an upgrade run.
'';
+ default = { };
type = types.attrsOf (types.submodule {
options = {
package = mkOption {