self: super:
let
-
- # Pending upstream inclusion in https://github.com/NixOS/nixpkgs/pull/93377
- fallback-backoff = self.python3Packages.callPackage ({ lib, buildPythonPackage
- , fetchFromGitHub, pytestCheckHook, poetry, pytest-asyncio, }:
- buildPythonPackage rec {
- pname = "backoff";
- version = "1.10.0";
- src = fetchFromGitHub {
- owner = "litl";
- repo = pname;
- rev = "v${version}";
- sha256 = "1jj0l6pjx747d2yyvnzd3qbm4qr73sq6cc56dhvd8wqfbp5279x0";
- };
- format = "pyproject";
- nativeBuildInputs = [ poetry ];
- checkInputs = [ pytestCheckHook pytest-asyncio ];
- }) { };
+ checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+ (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+ checkInputsName =
+ if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
fallback-git-cache = self.python3Packages.callPackage
({ buildPythonPackage, fetchgit, git, backoff, mypy, }:
buildPythonPackage rec {
pname = "git-cache";
- version = "1.3.0";
+ version = "1.5.0";
src = fetchgit {
- url = "https://scottworley.com/git-cache.git";
+ url = "https://git.scottworley.com/pub/git/git-cache";
rev = "v${version}";
- sha256 = "sha256-0HbtnS98im0sd2JIdUePBcspUskL2DY8ylQdyEC2sS0=";
+ hash = "sha256-g4TS/zX3e29Q3ThsCAX2wLLlYbi8fdux5uqAc+b/Oww=";
};
propagatedBuildInputs = [ backoff ];
- checkInputs = [ git mypy ];
+ "${checkInputsName}" = [ git mypy ];
doCheck = true;
checkPhase = "./test.sh";
- }) { backoff = self.python3Packages.backoff or fallback-backoff; };
+ }) { };
fallback-pinch = self.python3Packages.callPackage
- ({ buildPythonPackage, fetchgit, nix, git, mypy, git-cache, }:
+ ({ buildPythonPackage, fetchgit, nix_2_3, git, makeWrapper, mypy, git-cache, }:
buildPythonPackage rec {
pname = "pinch";
- version = "3.0.2";
+ version = "3.1.0";
src = fetchgit {
- url = "https://scottworley.com/pinch.git";
+ url = "https://git.scottworley.com/pub/git/pinch";
rev = "v${version}";
- sha256 = "sha256-bO0kMuaw/hkmDD1b8mkCDx0FAM6NIeUxvc+fOhHUXcs=";
+ hash = "sha256-qwbYDSGE6p1YU3AnOatXNoTUc284D1xPQs/tRS++VOM=";
};
+ buildInputs = [ makeWrapper ];
propagatedBuildInputs = [ git-cache ];
- checkInputs = [ nix git mypy ];
+ "${checkInputsName}" = [ nix_2_3 git mypy ];
+ postInstall = ''
+ wrapProgram "$out/bin/pinch" --prefix PATH : ${nix_2_3}/bin
+ '';
doCheck = true;
checkPhase = "./test.sh";
}) { git-cache = self.python3Packages.git-cache or fallback-git-cache; };