with lib;
let
cfg = config.system.autoUpgradeWithPinch;
+ pull-repo-snippet = ''
+ (
+ cd /etc/nixos
+ ${pkgs.git}/bin/git fetch
+ PATH="${pkgs.keyedgit cfg.keys}/bin:$PATH" \
+ ${pkgs.polite-merge}/bin/polite-merge --ff-only --verify-signatures
+ )
+ '';
+
auto-upgrade-script = pkgs.writeShellScript "auto-upgrade" ''
${pkgs.utillinux}/bin/flock /run/auto-upgrade-with-pinch ${
pkgs.writeShellScript "auto-upgrade-with-lock-held" ''
}
}
+ # Pull updates
+ ${pull-repo-snippet}
+
# Update channels
- (
- cd /etc/nixos
- ${pkgs.git}/bin/git fetch
- PATH="${pkgs.keyedgit cfg.keys}/bin:$PATH" ${pkgs.polite-merge}/bin/polite-merge --ff-only --verify-signatures
- ${pkgs.pinch}/bin/pinch update channels
- )
+ ${pkgs.pinch}/bin/pinch update /etc/nixos/channels
# Build
in_tmpdir ${config.system.build.nixos-rebuild}/bin/nixos-rebuild build