-self: super: {
+self: super:
+let
+ checkInputsAreNative = self.lib.hasInfix "nativeCheckInputs"
+ (builtins.readFile <nixpkgs/doc/stdenv/stdenv.chapter.md>);
+ checkInputsName =
+ if checkInputsAreNative then "nativeCheckInputs" else "checkInputs";
+in {
polite-merge = if builtins.hasAttr "polite-merge" super then
super.polite-merge
else
self.callPackage ({ fetchgit, git, stdenv, }:
stdenv.mkDerivation rec {
pname = "polite-merge";
- version = "1.0";
+ version = "2.4";
src = fetchgit {
- url = "https://scottworley.com/polite-merge.git";
+ url = "https://git.scottworley.com/pub/git/polite-merge";
rev = version;
- sha256 = "1q3iya5ifpcnmmvxhaphlvvq674yzwkgi3cyr6i3yflqks7zf81p";
+ sha256 = "1p6ivaay3bk4vvqqic7g23xrhkkq8z19zhsaxkav8kk90s2bmmza";
};
postUnpack = "patchShebangs .";
- checkInputs = [ git ];
+ "${checkInputsName}" = [ git ];
doCheck = true;
preInstall = "export prefix";
}) { };