self.callPackage ({ fetchgit, git, stdenv, }:
stdenv.mkDerivation rec {
pname = "polite-merge";
- version = "1.0";
+ version = "2.4.1";
src = fetchgit {
- url = "https://scottworley.com/polite-merge.git";
- rev = version;
- sha256 = "1q3iya5ifpcnmmvxhaphlvvq674yzwkgi3cyr6i3yflqks7zf81p";
+ url = "https://git.scottworley.com/pub/git/polite-merge";
+ rev = "v${version}";
+ hash = "sha256-WtxDKKc3/IkLahVnrbfBXj6DoX1Rbu0qrIZK7D4Z7hY=";
};
postUnpack = "patchShebangs .";
- checkInputs = [ git ];
+ nativeCheckInputs = [ git ];
doCheck = true;
preInstall = "export prefix";
}) { };